Eigener Firefox Sync Server mit Debian/Ubuntu

Das könnte Dich auch interessieren...

5 Antworten

  1. Leon sagt:

    Habe den Server so aufgesetzt wie in deiner Beschreibung ausser den teil mit der Optimierung. Der Server Läuft ( it works! ), aber ich komme immer auf die normale Firefox login seite.

    Als url habe ich die IP des Raspberrys eingegeben der als Firefox Sync server dienen soll. Der Server soll nicht aus den Internet ereichbar sein sonder nur von zuhause.

  2. Leon sagt:

    Habe es jetzt selber herausgefunden. Wenn der Firefox Server mit allen einstellungen läuft und die änderungen im Firefox Browser gemacht wurden, muss man sich im Browser unter Extras ( Bei Sync anmelden) erstmal ein Account bei Mozilla erstellen und die Synconisation läuft dann über eueren Server ab. Dieses sicht man an der Datenbank größe und den letztmaligen benutzten der Datei.

    Damit das Programm in hintergrund läuft sollte noch screen installiert werden und z.b. mit ( screen -dmS firefox make serve ) das Programm in der Instantz (firefox) dort laufen zu lassen.
    Mit screen -r wirde diese aufgerufen wenn nur diese Instantz läuft. Mit STRG-D kann man diese verlassen ohne das Programm zu beenden.

    • Matthias sagt:

      Hallo Leon, vielen Dank für die ausführlichen Infos. Du hast Recht, man muss sich dennoch mit einem Firefox Konto bei Firefox anmelden. Mann könnte zwar auch einen eigenen Auth Server aufsetzen, jedoch ist dies noch sehr experimentell, außerdem werden auf dem Auth Server keine Verlaufsdaten gespeichert, sodass ein eigener Sync Server dennoch sinnvoll ist.

      Auch deine Ergaenzungen zu „screen“ sind sicherlich für einige sehr hilfreich – danke 🙂

  3. Leon sagt:

    Hallo Matthias,

    aber ein Problem habe ich noch immer und zwar kann ich mit meinen Android Handy mit Firefox 57 kein sync machen. Ich melde mich mit den gleichen Daten an aber es funktioniert nicht. Die Adresse zu meinen Server ist aber die richtige.

    Hast du es vielleicht gelöst?

  4. Leon sagt:

    Da bin ich wieder 🙂
    ich habe meinen Fehler gefunden. Ich müßte in der syncserver.ini datei den wert allow_new_users und force_wsgi_environ auf true setzten und es ging sofort.

    Also für alle anderen die auf die Anleitung stoßen sollten die meisten dinge erklärt sein. Für mich ist es jetzt die beste die ich bis jetzt gelesen habe 🙂

    Danke Matthias 🙂

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.